Quake Wars demo details, date, and PC requirements announced

Recommended Videos

Are you hungry for some Enemy Territory: Quake Wars? Now that the game is done cooking, it looks like everyone will get a taste on Monday, September 10th, as the PC demo will be released. 

The Quake name has always been synonymous with top-end system specifications, and while this instance isn’t necessarily a ball-buster, you’ll still need a decently fast PC with a respectable video card. Of course, most avid PC gamers are probably ready to rock. If not, you’re stuck waiting for the PS3 or Xbox 360 release.

The PC demo will come with the final version of the Valley map, which has “undergone further balance improvements” based on feedback from beta testers. There will also be online play, LAN functionality, and bot support included in this demo. 

The Quake Wars development blog says that you’ll want to check back to see where the demo can be downloaded, but they’re looking to have it up everywhere they can, including at Yahoo, Nvidia, FilePlanet, and Fileshack.

Hit the jump to check out the required system specifications for this demo. 

SOFTWARE REQUIREMENTS

  • Microsoft(R) Windows(R) XP/Vista (Windows 95/98/ME/2000 are unsupported)
  • Microsoft DirectX(R) 9.0c (included)

HARDWARE REQUIREMENTS

  • CPU: Intel(R) Pentium(R) 4 2.8 GHz or AMD(R) Athlon(TM) XP 2800+ processor (Pentium 4 3.0GHz or equivalent for Windows Vista)
  • RAM: 512MB RAM (768MB for Windows Vista)
  • Video Card: 128MB NVIDIA(R) Geforce(TM) 5700 or ATI(TM) Radeon(TM) 9700 (full list of supported chipsets below)
  • Sound Card: 100% DirectX 9.0c compatible sound card
  • HDD Space: 750MB of free hard drive space, plus 200MB for Windows swap file
  • Internet: Broadband connection and service required for full gameplay and downloads. Features may change without notice.

SUPPORTED VIDEO CHIPSETS

  • NVIDIA GeforceFX Series (5700 or higher, not including 5700LE and 5700VE)
  • NVIDIA Geforce 6 Series (6200 or higher) NVIDIA Geforce 7 Series (7300 or higher)
  • NVIDIA Geforce 8 Series
  • ATI Radeon 9700 or higher
  • ATI Radeon X700 or higher
  • ATI Radeon X1650 or higher

[Via Shacknews – thanks, rishi]


Destructoid is supported by our audience. When you purchase through links on our site, we may earn a small affiliate commission. Learn more about our Affiliate Policy
Author