dark        

Your PS5 will now tell you if you're playing the PS4 edition of a cross-gen game

0

Maybe I WANT to play the PS4 version

Sony's PlayStation 5 sure has a lot of neat features, one of which being the ability to play the majority of your PS4 digital catalogue. However, in these cross-gen times, some players have found themselves running the PS4 edition of certain titles accidentally, while the shiny PS5 edition sits confused to one side saying "Whaddya want from me?"

Well, this should no longer be an issue. As spotted by Twitter user @Tidux, Sony has pushed out a small update to the PS5 dashboard that now specifically warns players what generation of a game they are about to boot. So if you're hitting Mortal Kombat 11, Assassin's Creed Valhalla, Call of Duty: Black Ops Cold War, Watch Dogs Legion, (you absolute maniac), or any other title that you might happen to own on both PS4 and PS5, you can now be sure you're getting all of that 4K, ray-tracing, adaptive trigger glory.

It's a small addition, but one that's both useful and very welcome. Now, about that extended storage...

PS5 now warns you if you're about to play the PS4 version of a game [PushSquare]

You are logged out. Login | Sign up

 
 
 

TwitterRedditEmailFacebook
 
Chris Moyse
Chris MoyseSenior Editor   gamer profile

Chris has been playing video games since video games began... still terrible at them. Former Saturday Night Slam Master, rambles nostalgically like Abe Simpson. I ain't here to fight, so let's no... more + disclosures


 


 



Filed under... #cross-gen #next gen #Patches #PlayStation #PS4 #PS5 #Sony #Update

READER COMMENTS LOADING BELOW...


LET'S KEEP THE COMMUNITY GREAT


You're not expected to always agree, but do please keep cool and never make it personal. Report harassment, spam, and hate speech to our community team. Also, on the right side of a comment you can flag nasty comments anonymously (we ban users dishing bad karma). For everything else, contact us!